登录站点

用户名

密码

路由协议-RIP(三):被动接口与单播更新

2已有 1593 次阅读  2013-04-22 21:43   标签RIP  被动接口  单播更新 

1、路由器被动接口的配置
由于以太口g0/0和g0/1连接主机,不需要向这些接口发送路由更新,所以,可以考虑将路由器的该接口设置为被动接口。
R1(config)#router rip                      
R1(config-router)#version 1                 
R1(config-router)#network 10.0.0.0          
R1(config-router)#network 172.16.0.0          
R1(config-router)#network 192.168.12.0
R1(config-router)#passive-interface GigabitEthernet0/0
R1(config-router)#passive-interface GigabitEthernet0/1
R2(config)#router rip                      
R2(config-router)#version 1                 
R2(config-router)#network 192.168.12.0
R2(config-router)#network 2.0.0.0          
 
2、debug ip rip    //该命令可以查看RIP路由协议的动态更新过程。
R1#clear ip route *
R1#debug ip rip
Apr  22 21;24;41.275;RIP;sending request on Serial0/0/0 to 255.255.255.255
Apr  22 21;24;41.283;RIP;received v1 update from 192.168.12.2 on Serial0/0/0
Apr  22 21;24;41.283;      2.0.0.0 in 1 hops
Apr  22 21;24;43.275;RIP;sending v1 flash update to 255.255.255.255 via Serial0/0/0(192.168.12.1)
Apr  22 21;24;43.275;RIP;build flash updata entries
Apr  22 21;24;43.275;      network 10.0.0.0 metric 1
Apr  22 21;24;43.275;      network 172.16.0.0 metric 1
从以上输出可以看出,路由器R1确实不向被动接口g0/0和g0/1发送路由更新。
PS:被动接口只能接收路由更新,不能以广播或组播方式发送更新,但是可以以单播的方式发送更新,配置单播更新的命令如下:R1(config-router)#neighbor A.B.C.D
 
3、路由器配置单播更新:
 


根据上图所示,路由器R1只想把路由更新送到路由器R3上,由于RIPv1路由协议采用广播更新,在默认情况下,路由更新将发送给以太网上任何一台设备。为了防止这种情况发生,把路由器R1的g0/0配置成被动接口。然而,路由器R1还想把路由更新发送给R3,这时必须采用单播更新,为指定的相信路由器R3发送路由更新。
路由器R1具体的配置如下:
R1(config)#router rip         
R1(config-router)#passive-interface GigabitEthernet0/0
R1(config-router)#neighbor 172.16.1.3

分享 举报